Tag: microsoft

IIS HTTPS Security

Posted by on December 3, 2015 | No comments

Recently I’ve been looking at the security of the internet facing systems at work. It’s amazing how many bits of software by default still ship with massively insecure settings.

One of my main focusses has been IIS, and as such the related software we use that is built on top of IIS – Forefront UAG and Forefront TMG.

There is a fantastic website from Qualys that will scan an HTTPS server, check the certificate and all the various options around ciphers in use and what capabilities are/aren’t available and then give you a score based on current best practices. This is also updated quickly and takes into account things like the Poodle vulnerability.

You can visit their SSLLabs site to check the current status of this site, or check your own.

There are a number of articles on the web (and on SSLLabs above) dealing with disabling SSLv2 and SSLv3, which is great but isn’t actually sufficient, and remembering to set all of these things is quite tedious.

I was pleasantly surprised to discover a fantastic powershell script that sets all of the required registry entries for Windows servers to allow you to score an A rating.

It’s important to point out that all of the latest and greatest security options for HTTPS will actually break backwards compatability with some earlier Android handsets, and (shock!) Internet Explorer 6… I’m not going to cover off any changes required if this is important to you, because it shouldn’t be.

Anyway, hass.de has a fantastic script to fix your Windows server schannel security settings. A reboot is required to take effect.

You can read about their options and download the scripts to get your Windows servers an A rating from https://www.hass.de/content/setup-your-iis-ssl-perfect-forward-secrecy-and-tls-12. They also cover the option you can change if you want to get an A+!

Tags: , , , , , ,

SCE2007 Failed to install agent

Posted by on July 6, 2010 | 3 comments

I’ve been doing more and more work with the System Center product suite of late, and suffice to say I have some big loves and some big hates about the whole thing.

My recent hate is System Center Essentials 2007. Thankfully, I actually quite like Essentials 2010.

Anyway, while installing the SCE2007 agent the other day, I encountered an odd error message while trying both a push install and a local install of the agent.

Error 25211.Failed to install performance counters.. Error Code: -2147023886 (The configuration registry key is invalid.).

Sadly, there’s not a lot on the web in relation to this error. The only pointer that might have helped was this technet article: How to manually rebuild Performance Counter Library values.

This starts out pretty nasty, involving copying files from your install media and hacking about in the registry, which Microsoft always massively caveats. The one item of help on the page was the command:

lodctr /R

According to the help, this will rebuild the perf registry strings and info from scratch based on the current registry settings and backup INI files. And accorting to the KB article: “/R is uppercase. You must have administrative rights on the computer to successfully perform this command.”

That did the trick for me and completely avoided all the nasty work of actually finding the install media for this server 🙂

I’ve included below a larger chunk of the installation error log below which will hopefully help people find this page via searches.
» Read the full post

Tags: , , ,

Powered by Wordpress and Stripes Theme Entries (RSS) | Comments (RSS)